Argon EON NAS Case Freezing My Raspberry Pi 4


I got a problem with my Argon EON NAS case and Raspberry Pi 4 setup. As soon as I plug in the Argon EON USB 3.0 bridge, my Pi either crawls to a standstill or won’t boot at all. Top screen’s working but can’t get into the Pi.

My Setup:

  • Raspberry Pi 4B 8GB
  • RaspiOS 64-bit
  • 256GB SanDisk Extreme PRO
  • Official power supply
  • Argon EON SATA Board v3.5
  • Samsung 870 QVO 1TB SSD

Haven’t even gotten around to mounting the SSDs yet.

Tried So Far:

  • Followed the setup guide—no luck.
  • Swapped power supplies—booted but froze soon after.
  • Updated bootloader with rpi-update—still no luck.
  • Started from scratch—same issue.

I think the SATA and Power boards might be the culprits, or maybe the Pi’s sucking up more power than it’s getting, although I’m using the official supply.

Anyone else run into this or have any fixes?

Latest: I am now sure the issue lies on the SATA board since the Raspberry does not boot with the board mounted.