Argon Eon install script with Ubuntu 22.04

Shoutout to @NHHiker who modified the Argon Eon installation script to work with Ubuntu 22.04. As of May 6th, 2022, the official script provided by Argon didn’t work. I hope the official script will eventually support the new Ubuntu 22.04 LTS release, but until then, you can get the modified script from:

https://raw.githubusercontent.com/JeffCurless/argoneon/main/argoneon.sh

curl -L https://raw.githubusercontent.com/JeffCurless/argoneon/main/argoneon.sh | bash

This post should be stickied.

1 Like

+1

I switched to Ubuntu Server 22.04 LTS after spending too many days fighting Raspian Lite over things that had nothing to do with the EON or RAID–I never could get it to update its repos or set its clock, for instance, and I hate when a system auto logs me in and doesn’t even prompt for a password when sudo is invoked.

Ubuntu actually behaves almost entirely like I think a Linux distro should, out of the box. (I’m primarily a Manjaro (Arch) user, so package management still feels weird).

I couldn’t have made the switch without @NHHiker 's script, and everything works almost entirely as I expect it to.

I’m having an issue with the EON fan and OLED not shutting down properly when I turn the device off (I have to actually pull the plug once the drives spin down), but aside from that, I’m left able to concentrate on actually configuring the EON the way I want it to be–or rather, fighting with the fan to try to get it down to an acceptable noise level. :stuck_out_tongue:

Yeah, I’m seeing the OLED not shutting down as well. The issue has to do with the way the service is being shutdown. As for the power not going off 100%… not sure what that is.

Thanks for the clarification. :slight_smile: Is that something that can be tweaked, or a limitation of the way Ubuntu works?

Are you seeing it, too?

If not, I’m wondering if it somehow has something to do with the third party 12v 5w PSU I bought to replace the stock one that failed. I noticed when I unplugged the PSU itself from the wall, that it took about a minute for the green power light to go off on the PSU itself–it’s got some seriously impressive capacitors.

Maybe it’s providing too much standby power and somehow still powering the fan.

@SinisterPisces @nhasian

So the issue with the service stopping not turning off the fan, or OLED has been fixed, code has been updated. For those that don’t want to uninstall/reinstall

edit /lib/systemd/system/argononed.service

Add:

ExecStopPost=/usr/bin/python3 /etc/argon/argononed.py FANOFF

After the ExecStart= and before [Install]

[Unit]
Description=Argon One Fan and Button Service
After=multi-user.target
[Service]
Type=simple
Restart=always
RemainAfterExit=true
ExecStart=/usr/bin/python3 /etc/argon/argononed.py SERVICE
ExecStopPost=/usr/bin/python3 /etc/argon/argononed.py FANOFF
[Install]
WantedBy=multi-user.target

Now when I shutdown the system with “Shutdown now”, the fan stops and the OLED is off. However, it still seems to be “powered on” somehow, as the button does not want to turn the system back on properly. Not sure what that is.

But this behavior does not have anything to do with this change, as it has been happening for a while. I suspect the on/off button functionality is not being reset properly.

How is everyone shutting down their EON? Using the command line (shutdown now or the equivalent), GUI or power button?

Just trying to figure out what’s going on with the scripts.

1 Like

Hello!

Thanks for the updated .service file. I assume there’s no issue using the argon-config tool to uninstall if I just want to-run the curl | bash command to do a fresh install?

I haven’t had a chance to switch to it, yet, but I wanted to answer your question about how I’m turning the unit on and off.

I don’t have a GUI or any web-interface NAS software (e.g., OMV) installed yet, so I’m using sudo shutdown now.

Right now, when I do that I have to then unplug the unit from the wall to stop the fan and unfreeze the OLED. It doesn’t automatically turn back on when I plug it back in; I have to press the power button.

Yes, you can run the argon-config tool to uninstall, and then reinstall with the curl command. No problem.

1 Like

I’m using the shutdown command to poweroff the Argon.

I will test the new service, I discovered the running fan recently.

I uninstalled using argon-config, rebooted then installed the latest version. This seems to have re-introduced the zombie process.

The previous modification had solved the zombie process issue. More positively no issues with the fan or OLED

Don’t know if others are having same problem with zombie process.

Show the zombie process please

Just want to say to the author, thank you very much for this script because I would have been completely stuck without it.

I hope that someone from Argon is going to update the official script very soon to support Ubuntu 22 because it has now been officially released.

Is thus script for the sever version or can it be used with the desktop mode?

@Cherry Either version should work, I set it up with a workstation version.

@NHHiker cheers for the info I tried it on the latest ubuntu desktop so must be a fault my end.

Post the issues, maybe it can be made better or display the issues better.