PCIe timeout with Argon Neo 5 NVME

I’ve just received a new Argon Neo 5 NVME case and am having problems.
My M.2 NVME SSD has been working brilliantly in an external enclosure via USB as a boot device.
Having followed the Argon instructions, I’m getting:
PCIe Timeout: 0x0001e08f
Failed to open device: ‘nvme’.

I’ve tried reseating the PCIe cable - same error.
I also get the same error whether the SSD is present or not.
I have the boot order set to try NVME first, then SD card. It does successfully go on to boot from the SD card. But no recognition of a PCIe device.

Any suggestions?


Possible error might be incorrect orientation for the ribbon cable? Make sure that the ribbon cable is install in the right orientation. If can help provide a photo on how the ribbon is installed.

the instructions are very clear on the ribbon orientation…

“Copper side of the strip should be facing the white side of the PCIe connector”

the ribbon is too short to connect to the NVME base any way other than the correct way.

I too am getting the PCIe timeout - if you read the other thread, you will find many others are having problems…

Here is the install. It is really tight.

Which other thread? I did try looking but couldn’t find anything.

Nice pic. ribbon looks ok at that end.
I think I made an error , you are Neo 5 and I was referring to Argon One v3 - sorry, my bad

Ribbon is installed properly. Only other thing is the compatibility of the the SSD drive used. Unfortunately, there are certain drives that does not work well with Raspberry Pi Pcie. May i ask what SSD is currently being tested?

It’s a WD Blue SN550.

Would you expect the PCIe timeout whether or not the SSD was connected?

Unfortunately WD SN550 is one of those drives with compatibility issue with Raspberry Pi PCIe. It does cause issue it being not detected during the bootup.process.

My Raspberry Pi 5 with Argon One V3 NVMe case is stuck when booting on
HID [02:01] 2.00 000001:02 register HID
I’ve tried the cable both ways round with the same issue. Is my “Integral 256GB M.2 NVMe 2230 PCIe Gen3 x4 SSD” compatible? It worked fine with a USB3.0 NVMe enclosure.

So, annoyingly, I needed to put in a micro SD card (with Raspberry PI OS on it) and boot the Argon cased Pi up, then run “curl https://download.argon40.com/argon-eeprom.sh I bash”, then reboot and it then booted to my NVMe. Micro SD card back out now and all working well. It would be nice if there was a way to configure it to just boot to the NVMe without having to use a micro SD card first…

So far, it is working fine with my “Integral 256GB M.2 NVMe 2230 PCIe Gen3 x4 SSD”, if you would like to add it to the compatible devices.

@trlaing ,

I think the reason for this is that your RPi5 shipped with an older bootloader than this 02/16/2024:

There appear to be some fixes required to support newer or exotic NVMe variants with their firmware behavior. So the one-time maneuver with an SD card may be the last/only chance to get the recently purchased NVMe working.

You probably could have booted off of the USB enclosure instead of having to use the SD card.

Good point, but by this time I had already pulled it all apart and installed the NVMe in the Argon case. Quickly imaging an old SD car lying around seemed like the easier option.