M.2 nvme expansion bd

Many thanks for this…am working on it right now! :slight_smile:

Hhmmm…followed instruction…nothing happened…nether PASS nor FAIL.
Where might that leave me please??

Is your board listed in the table at the bottom of the flashing tool. Maybe share a screenshot?

There’s the rub…the table didn’t populate for me!

It won’t populate if it doesn’t detect the drive. What make/model of NVMe drive have you got installed?

Thanks for getting back…would be nice to get to the bottom of this!
It’s a new…out of the packet… (un-formatted??) Kingston NV2 1TB SSD M.2-2280 PCIe Gen4 x4 NVMe

If you run Windows Disk Management, does it even show the disk?
If not, then worth checking the cable you’re using to ensure it’s a proper USB 3.0 cable, or if have a way of checking the drive is ok in another enclosure or computer.

Currently connecting using the ‘U’ connector supplied…and a USB3.0 extension cable,
Can’t get it to show (then format!) in Windows disk management.
Picking up a male to male USB3.0 cable tomorrow…that might help?
Heard some comments that the U connectors aren’t reliable!!?

It occurs that I never got around to replying on this thread!
Established that VID is 174C and PID is 55AA (in Win11 disk properties)…so returned board to supplier. Received replacement board with exactly same values…and Asmedia ‘fix’ doesn’t work with this board either! (table doesn’t populate with existing values, neither does ‘run’ produce any result)
Looks like this board will aso be returned!

I have the same board - does this mean that the update tool won’t work even if I do manage to borrow a friend’s Windows computer?? I have no way of trying it on a Mac. I did plug it into the Parallels Windows VM on my Mac but it wasn’t seen - I assumed it was to do with Parallels.

Whoops…should’ve updated this thread :roll_eyes:
The tool worked fine …when I realised that I should be connecting to PC via USB2.0, and not USB3.0
…then, all went swimmingly!!! :grinning:

Ahh, okay, so I’ll need to find a USB 2.0 connection to a Windows PC… does a standard USB-A male to USB-A male plugged into the board work?

Worked for me…let us know how you get on!
The male to male lead that I bought…is a USB3.0 (Blue!)…but could only get the update to run via a USB2.0 port on the PC

i updated the firmware but i receive this error: #1725 (NVMe pass-through support for Argon ONE M.2 Expansion Board (NVME)) – smartmontools

any ideas?


sudo smartctl  -d sat -A /dev/sda

Switch sda with which ever device your NVME is on.

1 Like

sudo smartctl  -d sat -A /dev/sdb
smartctl 7.2 2020-12-30 r5155 [aarch64-linux-6.1.21-v8+] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported scsi opcode

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

your problem is that smartmontools v7.2 does not support ASM2362. see this

@kulho i can confirm your patch worked like a charm, thank you for the steps how to fix this <3

So I tried a collection of cables and connections… finally got a cable that meant the table was populated with my board. Tried to flash the firmware and got an error and it failed.

This is getting infuriating - and no reply from Argon One customer service email address.

Finally sorted. Replacement board from PiHut. Updated firmware successfully using Windows in Parallels on my intel iMac - using the same cables etc as I tried on my M1 MacBook Pro which (again) didn’t work with the replacement board.

At least it’s done and all working properly now. (Still no comment/response from Argon One customer service!)